Evolution MK-249C MIDI Keyboard Mac OS X Problem

Mac OS X generally seems capable of dealing with just about anything you can throw at it. However upon connecting my trusty Evolution MK-249C MIDI keyboard up to my 2nd generation MacBook it steadfastly refused to play ball. This keyboard has always been instantly recognised by Windows XP and so it was surprising to encounter this.

The M-Audio website (M-Audio took over Evolution it appears) offered no real assistance. There was no driver available for Mac OS X 10.4.9 as the keyboard is supposed to be "Class Compliant" which apparently means it doesn't need one... strange.

Eventually after consulting some forums I found the fix. The problem seems to be related to Mac OS on the Intel MacBooks. There is a patch on the M-Audio site but only for MacOS 10.1.5. This must be downloaded and installed. Here is the link:


Upon restarting the OS the keyboard was recognised by Mac OS and GarageBand had no trouble talking to it.

So there you have it. A little odd but easily fixed. Even computers that "Just Work" have problems sometimes.


summer said…
thanks. this also works with evolution mk-449c and some other m-audio keyboard i had lying around.
Torley said…
BIG thanx! I was having this exact problem too, and after following your tip, it WORKED!

M-Audio's official support info didn't have any info on this, so without your page, it's likely I would've been stuck.

I'm looking for a way to get my MK-249C working on Windows XP SP3 now. It was last working fine on SP2 months ago, but then I disconnected it for awhile. Yesterday, I installed the drivers but it fails to be recognized. I wonder why?
William said…
I think I maybe a little late to this discussion! I have an Evolution MK-249C that I used for years on windows, but now that I made the switch, I can't get it recognised. To add to my woe, the M-Audio website no longer lists said patch (I'm using 10.5.7 on Macbook 5,3). Does anyone have a copy of this patch they'd be willing to send? I just purchased Logic Studio 8 (dang, 9 is out now), and I'd love to use my trusty clunker.


siokaos said…
The patch alone wont work for the newer OSX-- the kernel extension never loads. I figured out how to get it to work tonight.

My instructions
Gosta said…
You're link is no longer working. I'm struggling to get my Evolution Mk-361 to work with OS 10.6. If you have any information about how to do that it would be very appreciated. Post here or email me at:
vass said…
I too have had no joy getting the mk-249C to operate on my macbook OSX10.5.6.
If anyone can she light on this, if there are any valid uptodate drivers out there, PLEASE, please share your knowledge!
Winston said…
Y the link from siokaos no longer works, Im trying to use an evolution mk-361 via usb on a macbook pro with Mac OS X 10.6.2, if nyone knows how to do this PLEASE let me kno, jus having everything setup but not being ale to ue it because of drivers seems ridiculous
guy said…
This comment has been removed by the author.
guy said…
have the same problem. Im trying to run my mk-361 on my macbook pro running 10.6.2. Anyone please help.
javieth said…
I liked this blog because is easy understandable and very useful. for me Os X is the best software that i proved before. I really like this kind of technology.
buy viagra
Bridge Cameras said…
Great comments guys, thanks a lot
Anonymous said…
anyone got this working on newer version of OSX? Im dying here : )